12月

02

Compiereのコミュニティ版(バージョン3.30)を、データベースに
Oracle XEやPostgreSQLを使ってインストールしようとすると、
うまくインストールできないようです。

setupプログラムで、Oracle XE (Express Edition) を選択した場合は、
インストールはうまくいったように見えたのですが、
ログイン時にエラーが出てログインできませんでした。
XEに対応するためのスクリプトを実行しなければならないようです。
(ただ、スクリプトを実行してログインできるようになりませんでした)

PostgreSQLを選択した場合は、データベース接続チェックでエラーになります。
調べたところCompiereは、PostgreSQLではなく
PostgreSQL Plus(EnterpriseDB)に対応しているようです。

Adempiereは、Oracle XEとPostgreSQLに対応しています。